POWER BI CASE STUDY 01

Case Study 01:

Learning Objective: Extract->Transform->Load Fixed Column Width Text Files

Sample File Location:  ..\SampleData\SampleTxt\purchase.txt

1. Open Power BI

-]
T

Add data to your report

Once loaded, your data will appear in the Fields pane.

= il @

Import data from Excel Import data from SQL Server Paste data inta a blank table Try a sample dataset

Get data from another source —

2. Click on Get Data and More:
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3. Select txt/csv and then click on Connect:

X
Get Data
Search Al
Al @ Excel Workbook ~
File B s
Database
Power Platform o 0N
i Folder
Online Services & ror
Other W
£ SharePoint folder
SQL Server database
@ Access database
SQL Server Analysis Services database
Oracle database
1BM Db2 database
1BM Informix database (Beta)
1BM Netezza
MySQL database b
Certified Connectors | Template Apps Connect

4. Select the purchase.txt from the file browser

Z 1 ¢ Samplefa
o Ste  View
- i » This PC » Mew Volme (0} > Power3l » Day07 > SampleData > Sampleft
fr - ype siee
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& pawes . Do modlid: 17052022
st -
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[ Documents
& Downloads
D Music
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5. Click on Transform

purchase.txt

File Origin

estern European (Windows] ~ B

Calumnl

Page No. : 1

Date Doc Re Supplier Name Purchase Account Amount...

12-12-2021 1 GRAHAM AGENCIES & INDUSTR CHEMICA.
14-11-2021 2 SRI KRISHNA CHEMICAL INDU CHEMICAL.
14-11-2021 3 RAMAVILAS TUBE WORKS, SIV TUBE PUR...
26092021 4 PUNITHA LAKSHIMI TUBE WOK TUBE PUR...
22-11-2019'5 SRI PERIVANDAVAR TUBE WOR TUBE PUR.
23-11-2019 6 ViJI TUBE WORKS TUBE PURCHASE 8,418...
23-11-2019 8 RAMAYILAS TUBE WORKS, SIV TUBE PUR...
23012022 7 THIRUPATHI & CO.,, SIVAKA CHEMICAL P.
26-11-2019 9 THE METAL POWDER CO. LTD. CHEMICAL...
20022022 10 LAKSHMI PAPER TUBE WORKS, TUBE PU..
27-11-2018 11 CYGNET INDUSTRIES, SIVAKA CHEMICAL..
28-11-2019 12 GRAHAM AGENCIES & INDUSTR CHEMIC...
28-11-2019 13 SRI PERIYANDAVAR TUBE WOR TUBE PUL.

29112010 15 KARTHICK PUNCHING BOARD PURCHAS...

O The data in the preview has been truncated due ta size limits.

6. Enable View->Monospaced

1! & = | Untitled - Power Query Editor

- Home Transform Add Column View Tools Help

D Formula Bar [ | ponospaced [[] Column distribution E:I [] Always allow D =
Show whitespace [] Column profile g A=
Query Go to Advanced Query
Settings [ Column quality Column Editor  Dependencies
Layout Data Preview Columns Parameters Advanced Dependencies

Queries [1] < fx = Table.FromColumns({Lines.FromBinary(File.Contents:

™ purchase . A% Columnl E
1
2
3 Page No.: 1
4
5 Date Doc Re Supplier Name Purchase Account A
6
7 12-12-2021 1 GRAHAM AGENCIES & INDUSTR CHEMICAL PURC...
8 14-11-2021 2 SRI KRISHNA CHEMICAL INDU CHEMICAL PURCHA...
9 14-11-2021 3 RAMAVILAS TUBE WORKS, SIV TUBE PURCHASE ...
10 26-09-2021 4 PUNITHA LAKSHIMI TUBE WOK TUBE PURCHASE ...
11 22-11-2019 5 SRI PERIYANDAVAR TUBE WOR TUBE PURCHASE ...
12 23-11-2019 6 VUI TUBE WORKS TUBE PURCHASE 8.
13 23-11-2019 8 RAMAVILAS TUBE WORKS, SIV TUBE PURCHASE ...
14 23-01-2022 7 THIRUPATHI & CO.,, SIVAKA CHEMICAL PURCHAS...
15 26-11-2019 9 THE METAL POWDER CO. LTD. CHEMICAL PURCH...
16 20-02-2022 10 LAKSHMI PAPER TUBE WORKS, TUBE PURCHASE ...
17 27-11-2019 11 CYGNET INDUSTRIES, SIVAKA CHEMICAL PURCH....
18 28-11-2019 12 GRAHAM AGENCIES & INDUSTR CHEMICAL PURC...
19 28-11-2019 13 SRI PERIYANDAVAR TUBE WOR TUBE PURCHASE ...
mn 70119010 1R WARTLICK DEIRICLIINGS nAADN DIIRCUAQES
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7. Increase the column width as necessary:

T

8. Select Home->Remove Rows->Remove Top Rows

1| & = | Untitled - Power Query Editor

- Home  Transform  AddColumn  View  Tooks  Help

=% T, p— 4 [ Properties B | 4
P = i -5 i
S ‘_ L® ko It € [akenceddor = X i E
Close&  Mew Recent Enter Datasource  Manage Refresh - " Choose  Remave Keep. MWW
Apply™  Saurce™ Sources™ Data settings  Porameters™  Preview — Manage Columns * Columns™  Rows ™ | Rows ™ Column~ By 32
Close New Query Data Sources  Parameters Query Manage Columns  Reduce R sort T
Queries [1] < fi = Table.FromColumns({Lines.FromBinary(File.Cantents("D:\Pou
1 purchase . A% Columnl
1
2
3
4
5 Date Doc Re Supplier Name Furchase Accour
6
7 12-12-2021 1 GRAHAM AGENCIES & INDUSTR CHEMICAL PURCHI
8 14-11-2021 2 SRI KRISHNA CHEMICAL INDU CHEMICAL PURCH!
-
F  Remove Top Rows
E-Eﬁ, Remove Bot Rows
-
55 Remove Alternate Rows
E'ﬁ Remove Duplicates
[;5] Remove Blank Rows
% Remove Errors

9. Inthe dialog box Enter 4 and Select Ok.

Remove Top Rows

Specify how many rows to remove from the top.

Number of rows

4 1]

oK
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10. Click on Home->Split Column->By Positions

1) o v | utted - Power Qusry Editor
Home  Tombm G vew

-x — -
-t & = X

Cooen  bew | fent B Do o o Koy R
Wb someoomm- O g remene Columa ot~ By P
chsa o ey O — MaageCotns a5
Queries [1] < fx | = Table.skip(snurce,4)

= puchase

SugE Wame Furchase Account

i GRANAM AGENCIES & INDUSTR PURGHASES

2 1 PRI FURCHASES
3 RAMAVILAS T
4 PUNITER LaRSHD

B RANAVILAS TUBS WORKS, SIV
7 THIRBATEI & CO.,, STVARA CH FURCRASES

FURCHASES

S THE NETAL FOWDER GO. LTD. CHI
. B FoRcHRsE
aa

AL PURGHASES
FURCHASES
F TUEE EURCHASE
BOASD PURCEASES

c

16 LAKSHMI FAPER TUSE WORKS, TUBE FURGHASE
501 SELVA VINAYAGR FAEER & BO BORRD FURCHRSES

FURCHASES
PURCHRSES

1 GRAMAM ASENCIES & INDUSTR GEI

2 SRI FRISENA CHEMICAL INDO CE

By Delimiter
By Number of Characters
By Positions %
By Lowercase to Uppercase
By Uppercase to Lowercase
By Digit to Non-Digit
By Non-Digit to Digit
11. Enter the Column Positions (from 0 index — First column starts at 0 position and not 1%) as
below and Click on Ok.

X
Split Column by Positions
Specify the positions at which to split the text column.

Positions

| 0,6,16,25,51,71,88,97,109] 1 |

I» Advanced options

oK

12. Right Click on Column 1 Header and Remove that empty Column

1| & = | Untitled - Power Query Editor

File Home  Tramsform  AddColumn  View  Took  Help

EIX | T = Y ' Properties r Lp! 8 T

& |

-t == | e L& [ Advanced Editor - x g [
Cose&  New fecom Erter Daasoure  Mansge  Refesn o . Choose  Remove  Keep Remove Split
Apply~  Source~ Sources~ Data semlings  Paramelers ™  Preview s L Nt Columns = Columns > Rows™ Rows~ Column
Clase New Query Data Sources  Parameters Guery MarageColumns  Reduce Rows  Sort

Querles [1] < fr || = Table.TransforncolunnTypes(#-split column by Po:

T purchase (=8 rﬂ»» Column1.2 ~| M Column1.3

Copy

1 AT Doc Re
5 % Remove
S Remove kther Columns

7 Duplicate Column =
- Fi Add Column From Examples... =
6 Remove Duplicates .
= Remove Errors =
s Change Type . =
= Transform B Z
10 L2 Replace Values... 7
1 Replace Errors.. 5
12 " split Column ' 10
13 = Group By.. 11
14 il ' 12
15 §1 Unpivot Columns 13
16 Unpivot Other Columns =
T Unpivot Only Selected Columns =
18 =} Rename. 5001
19 Move . 3
20 Drill Down 2
21 Add as New Query 3
22 26-09-2021 4
23 22-11 5
24 23-11-2019 &
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13. Same way Remove the Column 9 which is empty: (Right Click column header and Remove)

_- By Copy
5 Refgve
Remove Other Columns
Duplicate Column
Fil Add Column From Examples...
Remove Duplicates
Remove Errors
Change Type
Transform

4 Replace Values

Replace Errors.
[y split Column
= Group By..
Fill
S Unpivot Columns.
Unpivot Other Columns
Unpivot Only Selected Calumns
=l Rename..
Move
Drill Down
Add as New Query

14. Select all the columns (Press Ctrl + A on Keyboard or Click on the First Column and Pressing
Shift Key Select the Last Column by Mouse). Right Click on any Column Header — Select
Transform->Trim to remove all Whitespaces

fx = Table.RemoveColumns(#"Changed Type",{"Columni1.1", "Columnl.9"})

. A8 columnl.2 T j| ABc Columnl.5 |z\ 2Bc Columni
7 Copy
1 | Date Doc Re |, Purchase Account
* Remove Columns
= Eeeee | 4
Remove Other Columns
3 [EZ2=E2 2021 1 CHEMICAT. PURCHASES 1le,00
[ Add Column From Examples...
4 34112021 2 CHEMICAT. PURCHASES =]
Remove Duplicates
5 [14-11-2021 2 TUBE PURCHASE 8
Remove Errors
6 |26-059-2021 < N TUBE PURCHASE ]
32 Replace Values...
1 2 =20410 5 il TUBE PURCHASE 10
1 »
8 [23-11=2019 6 TUBE PURCHASE 8
Change Type v
9 23112019 8 e e e 10
Transform b lowercase
10 | 23-01-2022 7 7
UPPERCASE
11 |26-11-2015 5 Merge Columns b =]
=, Capitalize Each Word
12 |20-02-2022 10 Group By... - 12
il . rim
13 27-11-2019 11 33 Unpivot Columns | Se
14 |28-11-2019 10 Unpivot Only Selected Columns Eledn g
= Length
e ove v
15 28112019 13 JSON 2]
16 29-11-2019 15 KARTHICK PUNCHING XML 2
17 et =201 16 LAKSHMI PAPER TUBE .. TUBE PURCHASE 14
18 2031019 5001 SELVA VINAYAGA PAPE.. BOARD PURCHASES 98

15. Click ;Ffainéfarm—>Use First Row és Headers to Promote the Header Row

1| & = | Untitled - Power Query Editor

Home  Transform  AddColumn  View  Tools  t

p— OB, 58 DataType:Text= L, Replace Val
= (B refserows T Detect ata Type [ Fil -

G';y"’ L:;‘H‘:;’  HcoftRows =] Rename 7., Pivot Colun
Table Any Colur

Queries [1 <
[T} purchase =8}
1 o
2=
3 12
4 |14
5 14
6 |26
7 |=
g |23
9 23
10 23
11 |26
12 20
13 |27
14 |28
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16. Click on the Dropdown Button of Date Column and Deselect “Blank” and “--------"
< f\ = Table.TransformColumnTypes(#"Promoted Headers”,{{"Date”, type t
. M Date |- ~ | ABc Supplier Name ~ M Pu

4| Sort Ascending

%l Sort Descending 1 GRAHAM AGENCIES & IN.. CHEMIL
2 SRI KRISHNA CHEMICAL.. CHEMI
- 3 RAMAVILAS TUBE WORKS.. TUBE
4 NITHA LAKSHIMI TUE.. TUBE
Remove Emply s RIYANDAVAR TUB.. TUBE
Text Filters * e TUBE
8 WORKS... TUBE
[Search ]
7 S.. CHEMI
W (Select All c— = PETAL POWDER CO... CHEMI
O (blank) 41 LAKSHMI PAPER TUBE W.. TUBE
O e dfp— 11 CYGNET INDUSTRIES, S.. CHEMI
0161200 12 GRAHAM AGENCIES & IN.. CHEMI
1-02-

B 01-02-2020 N 13 SRI PERIYANDAVAR TUB.. TUBE

¥ 01-06-2020
15 EARTHICK PUNCHING BOARL

¥ 01-07-2020
16 LARKSHMI PAPER TUBE W.. TUBE

¥ 01-08-2020
5001 SELVA VINAYAGA PAPER.. BOARL

¥ 01-09-2020
1 GRAHAM AGENCIES & IN.. CHEMI

¥ 01-10-2020
H SRI KRISHNA CHEMICAL.. CHEMI

¥ 02-01-2020
B 02-03-2020 3 RAMAVILAS TUBE WORKS.. TUBE
¥ 02-06-2020 4 PUNITHA LAKSHIMI TUS.. TUBE
% 02-07-2020 5 SRI PERIYANDAVAR TUB.. TUBE
% 02-12-2019 & VIJI TUBE WORKS TUBE
¥ 03-01-2020 8 RAMAVILAS TUBE WORKS.. TUBE
¥ 03-02-2020 v |7 THIRUPATHI & CO.,, S.. CHEMI
"=_oa o3 3can. ] THE METAL POWDER CO... CHEMI
. List may be incomplete. Load more | 14 LAKSHMT BAPER TUBE W.. TUBE
11 CYGNET INDUSTRIES, S.. CHEMI

oK

12 GRAHAM AGENCIES & IN.. CHEMI
30 28-11-2019 13 SRI PERIYANDAVAR TUB.. TUBE
31 | 28-11-2019 15 KARTHICK PUNCHING BOARL
32 29-11-2019 16 LAKSHMI PAPER TUBE W.. TUBE

17. In the same window Scrp_ll down to th_e E_r]q_and Deselegt ”Datefi__a_lso

4| SortAscending | |

| Sort Descending 1 GRAHAM AGENCIE
= 2 SRI KRISHNA CE
2 RAMAVILAS TUBE
Vo Clear Filter
’ 4 PUNITHA LAKSHI
Remove Empty 5 SRI PERIYANDAV
Text Filters rle VIJI TUBE WORK
E] RAMAVILAS TUBE
Search
7 THIRUPATHI & C
i £3mUd-eUeU
¥ 29-06-3020 A l° THE METAL POWL
¥ 29-07-2020 10 LAKSHEMI PAPER
¥ 29-08-2020 11 CYGNET INDUSTE
¥ 29-09-2020 12 GRAHAM AGENCIE
¥ 29-11-2019 13 SRI PERIYANDAV
¥ 29-12-2019 15 KARTHICK PUNCE
» 30-01-2020 16 LAKSHMI PAPER
¥ 30-05-2020 5001 SELVA VINAYAGE
 30-06-2020 1 GRAHAM AGENCIE
¥ 30-07-2020 2 SRT SHNA CE
¥ 30-09-2020 3 VILAS TUBE
¥ 30-11-2019 4 PUNITHA LAKSHI
o 30-12:2019 5 SRI PERIYANDAV
& 31-01-2020 VIJI TUBE WORE
¥ 31-07-2020
RAMAVILAS TUBE
¥ 31-12-2019
v |7 THIRUPATHI & C
%Date
= THE METAL POWL
| List may be incomplete. Load more | g TAKSHMI PAPER
T4, CYGNET INDUSTE
OK
12 GRAHAM AGENCIE
30 28-11-2019 13 SRI PERIYANDAV
31 |29-11-2019 15 RARTHICK PUNCE
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18. Click on ABC button in the left end of the Date Column Header and select Using Locale

] | & = | Untitled - Power Query Editor

=,

Transform Add Column View Tools Help

E‘;H Transpose Data Type: Text ™ 1, , Replace Values ~ E"-)g Unpivot Columns = Il

— ik
(2 Reverse Rows 7 Detect Data Type Fill ~ & Move ~ —‘
Group Use First Row Split  Fc
5 P e endere e M CountRows =] Rename 3. pivotColumn [ Convertto List i
Table Any Column
Queries [1] < f.t = Table.selectRows(#"

7 purchase =

AP DocRe
Decimal Number e
Fixed decimal number
‘Whole Number
Percentage

Date/Time

Date

Time

) Date/Time/Timezone
Duration

Text

True/False

Binary

Using Loc’ele...

14 | 25-11-2018 Ly 15
15 | 29-11-2019 16
16 30-11-2019 5001

19. Select Date as the Data Type and “English India” as the Locale.

%
Change Type with Locale

Change the data type and select the locale of origin.

Data Type

Date M
Locale
English (India) -

@ sample input values:

29-03-2016 b
29 March 2016

29 March

March, 2016

oK

Cancel

20. Click on ABC of the Doc Re Column and Select Whole Number
= Table.TransformColumnTypes(#"Filtered R

2-12-2021 1.2 Decimal Number A HAM
1-11-2021 $  Fixed decimal number T KR
4-11-2021 123 mhole Number e
0
5-09-2021 7o Percentage NITH
2-11-2019 B Date/Time I PE
3-11-2019 Date U1 T
3-11-2019 O Time MAVT
5-01-2022 @@) Date/Time/Timezone —_—
. .
5-11-2019 @ Duration F ME
B
7-02-2022| Fc Text KSHM
7-11-2019 % True/False e
3-11-2019|[F] Binary RHAM
Brld=2015 Using Locale... 5
9-11-2019 15 KARTHI
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21. Select Supplier Name and Purchase Account columns by Clicking on the Supplier Name
column header and Pressing Ctrl Key Clicking on the Purchase Account Column Then Right
Click on any of the column headers Select Transform->Capitalize Each Word to make the
uppercase data to proper text.

- Ab 5 |T‘ ABc A t .T
Copy s 16,00, 000.00
2 smr kmrs % Remove Columns s 3,100.00
B o Remove Other Columns 8,145.00
W Add Column From Examples... 9, 600.00
5 SRI PERI Remove Duplicates 10,843.75
6 VIJI TUB Remove Errors 8,418.50
B oo 4, Replace Values... 10,451.00
7| THIRUPAT Fill " s 7,250.00
9 THE META Change Type " s 71,679.60
10| LAKSHMT Transform x lowercase
11 CYGNET I Merge Columns UPPERCASE
12 GRAEAM A'E, Group By.. Capitalize Each Wor%
13 SRI PERI S5 Unpivot Columns e
15 KARTHICK Unpivot Other Columns Clean
16 LAKSHMI Unpivot Only Selected Columns Length
)01| SELVA VI Move » JSON
XML
1 GRAHAM AGENCIES & IN.. CHEMICAL PURCHASE JREes
2 SRI KRISHNA CHEMICAL.. CHEMICAL PURCHASES 3,100.00
3 RAMAVILAS TUBE WORKS.. TUBE PURCHASE 8,1459.00
4 DITNTTHA TAWCHTMT TITR TITRRE DITRAHASE a ann nn

22. Click on ABC of Amount Column and select Fixed Decimal Number to make it Currency:
pe text}, {"Purchase Account”, Text.Proper, typ

| - A company

Decimal Number JTKUMAR

aaE $  Fixed decimal number URUMAR
123 le Number ——

% Percentage Em——

LD_'@ Date/Time UKUMAR

Date TRUMAR

@ Time bicooan

Eas @é Date/Time/Timezone ——
- @  Duration —
A Text beomnt

ises %/ True/False UKUMAR
ses [El Binary JKUMAR
Using Locale... PRUMBR

2729000 RAJKUMAR
14,220.00 RAJKUMAR
98,676.60 RAJKUMAR

ises 10,00,000.00 RAJKUMAR

23. Right Click on the purchase query (in Left side Queries area) and select Reference

Queries [1] <

T purchase - .
? B2 Copy =
Paste 1
> Delete 2
=] Rename g
4

Enable load
Include in report refresh 2
_ 6

Bz Duplicate
@ Ref !
erence
L5 8
Move To Group 4 9
M U

ove Up a

Move Down
1
Create Function... 12
Convert To Parameter 13
[ Advanced Editor 14
E‘\D Properties... 15
16
17



24. Double Click on “purchase (2)” and rename the query as Suppliers

Queries [2]

Ezs] purchase
= Suppliers
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25. In the Suppliers Query Right Click on the Supplier Name and Select Remove Other Columns

B
Graham Ager
Sri Krishn: LXJ
Ramavilas 1
Punitha Laj
sri Periyar
Viji Tube ¥
Ramavilas 1
Thirupathi

The Metal }

S o N ®m ey W N e

Lakshmi Pag 1.,1
11 cygnet Indy
12|Graham ager |l
13 Sri Periyar =
15 Karthick P1
16 Lakshmi Pa}%

5001 Selva Vinaj

Graham Ager

Sri Krishng =]

Ramavilas 1

Punitha Laj

E—Tl AP Purchase Account 'El $ Amount
P —

Copy
Remove
Remove Other E}olumns

Duplicate Column

1¢

Add Column From Examples...
Remove Duplicates

Remove Errors

Change Type »
Transform »
Replace Values...

Replace Errors...

Split Column >
Group By...

Fill »
Unpivot Columns

Unpivot Other Columns

Unpivot Only Selected Columns 1c
Rename...

Move 4
Drill Down

Add as New Query

1

2

3

4

5 sri periyar
6 Viji Tube Works

2 Ramavilas Tube Works..
7 Thirupathi & Co.,, S..
9

The Metal Powder Co...

26. Click on Home->Remove Rows and Select Remove Duplicates

Tube Purchase
Tube Purchase
Chemical Purchases

Chemical Purchases

d i = Untitled - Power Guery Editer

Home  Tarsform  AddColema  View  Took

-t | a
Closed  Newd Recent Enler Ditasouce  Mansge  Refreh
Apply”  SourceMsources~ Data  setings  Rarameters”  Preview”

o Query Data Saurces  Parameters

<

Help

i roperies B - -
2 Advanced Editar b=

Manage *

Keep Remove
Rome-

hows  sort

= 2 Supplier Mame

Eﬁ Remove Top Rows
=g

an Remove Duplicates

l__)l. Remove Blank Rowlb

|’i Remove Errors

Remove Bottom Rows

1| Graham Agencies
2[sri krishna cnes

3 Ramavilas Tube 1

Remove Alternate Rows

10
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27. Click on the Dropdown button of Supplier Name column and Select Sort Ascending Order

< fx = Table.Distinct(#"Removed Other Columns")

[, 28 Supplier Name

8| Sor‘tAscenng
£l Sort Descending

Remove Empty
Text Filters

Search

<

(Select All)
Amuthu Poly Packs,, Sivak

Arulkumar Cuting,, Sivaka

Aswin Lorry Service, Siva
Cygnet Industries, Sivaka
Ganesh Traders, Sivakasi
Gopika Traders, Sivakasi
Graham Agencies & Industr
Jothi Tex, Sivakasi

Karthick Punching
Karuppasamy Cutting,, Siv
Kumar Tube Works, Sivakas
Kumutha Tube Sri Spark Fi
Lakshmi Paper Tube Works,
Laxmi Impe, Sivakasi

Lmp Tube Works, Sivakasi

IRRRKRKRRRRRRRARRRRRR

Murugan Printing Tape Fac v

=

20 [ ——
28. Same as Steps 23 to 27 Create Accounts query also for Purchase Accounts Column and the
query should look like the one below:
Steps to be done:
Right Click on the purchase query and select Reference
Rename the new referenced query as Accounts
Right Click on the Purchase Account Column and select Remove Other Columns
Right Click on the Purchase Account Column and Remove Duplicates
Click on the Dropdown button of Purchase Account Column and Select Sort
Ascending.

m oo T o

Queries [3] < fr = Table.Sort(#"Removed Duplicates",{

5=s| purchase [T, 4B Purchase Account -1

&= Suppliers 1 Board Purchases
[T Accounts Chemical Purchases
General Purchase
Label Purchase

Paper Purchase

[=a 0 LY B 0 TS I\ E

Tube Purchase

11
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29. Click on File->Close and Apply

Clase & Apply N
Apply
Clase

Save

H
B s

% Options and seftings »

0 Help ,

30. Now the data got Extracted, Transformed and Loaded to Power BI.

£ search
File Home Help  External Tools
Mo [ [2 B A L4 (t &
= — E ¢
@ [a B[ y B3 =g & 4 AR KA
Get  Excel Data SQL FEnter Dataverse Recent  Transform Refresh  Manage New New New Manage View = Q&A Language Linguistic ty | Publish
data~ workbook hubv Server data sources v data~ relationships ~ measure column table roles  as setup ~  schemav
Clipboard Data Queries Relationships Calculations Security QA Sensitivity Share ~
sl Properties »  Fields >
~ General ‘}3 Search
[E] Accoun O Mame
ccounts - B Accounts
Suppliers
Purchase Account L A OCEETE
Collapse ~ Description B purchase
N ¥ Amount
Enter a description
Company
[ pate
¥ DocRe
Row label
Purchase Account
Select a row label ~
Supplier Name
*
— P Key column et
Select a column with unique values ~
3 Amount Supplier Name
Company Is hidden
£ Date No O—
¥ Docfe

Is featured table
Purchase Account

No O—
Supplier Name Edit
Verifi
v Advanced
Collapse ~
*
-
Suppliers [l
Supplier Name !
Collapse ~

Alltables [

—— 0% (O3

12



