Power Bl Case Studies:
Case Study 1: (Power Query)

Objective: To reconcile GSTR 2A Returns with Purchase Journal using Power Query ETL
(Extract, Transform and Load) features.

Source Files:

1. Three months GSTR 2A as *.json files
2. Three months Purchase Journal Report as Excel Workbook

Problem Statement:

1. The Excel file contains two sheets one for purchase journal with suppliers name and
without their GSTIN. Another sheet contains the list of suppliers with their GSTIN.

2. The JSON files have nested tables and we need to reconcile with the B2B table which
contains the suppliers data.

3. From the next month onwards, we need to automate the cumbersome process.

Overview of steps:

1. Use extract from folder feature to extract multiple json files and identify B2B table.

2. Keep only the relevant fields for reconciliation from the above table.

3. Extract purchase journal data from Excel file and merge the same with GSTIN table to
get the GSTIN details of the suppliers.

4. Reconcile the both JSON and PJ tables by merging with INNER JOIN of common fields.

5. Find unreconciled JSON and PJ by merging with LEFT ANTI and RIGHT ANTI of common
fields.

Detailed Steps:

1. Open Power Bl and create a new project. Click Home Tab -> Get Data -> More to
select Get Data from folder and select the Folder option and click Connect.
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2. Select the folder where JSON files are kept.

Folder

Folder path
D\PowerBl_Projects\ICANGSTReconciliation B rowse§

3. Click Transform Button. Combine files can be clicked only when all the files are having
the same structure and already clean and no transformations required. Since we need
to transform the files and having Excel file also in the same directory we need to click

Transform.
o X

D:\PowerBI_Projects\ICAIN\GSTReconciliation

Content Name Extension Date accessed Date modified Date created Attributes

Binary Plxlsx lsx 18-04-2024 16:28:06  18-04-2024 16:27-24 | 18-04-2024 16:28:06 Record D:\Pa
Binary R2A_1DGACFRB490B1ZC_R2A_others_0.json .json 18-04-2024 16:28.06 18-04-2024 15:47:21 18-04-2024 16:258:06 | Record D:\Pa
Binary R2A_10GACFRB490B1ZC_R2A_others_0_1json json 18-04-2024 16:28:06  18-04-2024 15:48:10 18-04-2024 16:25:06 | Record D:\Pa
Binary R2A_10GACFRB490B1ZC_R2A_others_0_2 json | json 18-04-2024 16:28:06  18-04-2024 15:47-21 | 18-04-2024 16:28:06 Record D:\Pa
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4. Click on filter button of Extension column and select only JSON files as in the image
below:
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5. Confirmthe M Language formula filtering only .json extensions.
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6. Right Click on Content Column header and select Remove Other Columns since we
don’t require other than the content column:
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7. Now also we should not click Combine files button. The reason is: GSTR2A JSON files
are not having the same structure always. Some may have B2B tables, some may not



have. Hence, we have to Right Click on Content column header, Select Transform ->
JSON. By this way we are telling Power Query that, each file should be separately
transformedas JSON files.
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8. We can see that JSON files are transformed from Binary to Records. Click on Expand
Table button as shown in the image below. Click Ok.
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9. Since we need only the B2B List for reconciliation purpose, Right Click on B2B Column
and Select Remove Other Columns.
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10. Again click Expand Button of B2B Column. Now we need to select Expand to New Rows
(since itis a list).
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11. Now the lists are expanded to new Records. Again click Expand Button. This time

remove the check mark on Use original column name as prefix since we don’t require
and click Ok.
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12. The records are expanded to various columns. Remember JSON files can have nested

tables. These nested tables are treated as Lists and Records in Power BI. Lists are
columns, Records are rows of data in columns. So, our next step is to Expand to new
rows if they are lists and Expand if they are records to columns until we don’t have any
more lists and records. Doing so, we get a flat table of GST B2B Data. Following
screenshots show this:
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13. Rename the Query name to JSON and Select Choose Columns in the Home Tab to

choose only the required columns for reconciliation.
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14. Choose only the required columns as shown in the image.
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15. Change the type of ctin and inum columns as text by selecting multiple columns (by
pressing Ctrl key and clicking on the headers) and right click on any of the column
selected headers then select Transform->Change Type-> Text
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16. Same way select the columns val, csamt, samt, txval, camt and change the type to
Fixed Decimal number (since they are currency). Column idt can be changed to date as
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well.
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Now we can proceed to extract the Purchase Journal data from Excel file.

Right click on empty area of Queries area and select New Query->Excel Workbook and

select PJ.xlsx file.
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18. Select both the sheets GSTIN and PJ, then click Ok.
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19. As in the previous case, change the type of currency fields Goods Value, Cgst A/c, Sgst

A/c, Total to Fixed Decimal number. We can select Replace Current in the window to
replace the type.
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20. In the GSTIN query, we can see that Account Name and GST are not treated as column
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headers, so let us promote them to headers by clicking Transform -> Use First Row as
Headers.
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Close&  Mew  Recent Enter Manage  Refresh — ) Choose Remove  Keep | % = .
Apay=  Source~ Sourcer= Data Parameters = prenew= [T Mansge Columes+ Columne» Rows= | [— 2B Transpose ataType:Text » 4, , Replace Values » 5 Unpivot Columns ~
New Query Parameters Query Manage Colum pede o o C
(8 Reverse Rows tect Data Type [T] Fill ~ ¥ Move ~
< fc | = Table.TransformColumnTypes(GSTIN Sheet, {{"Column1”, ty  Group |Use First Rowl - Split
= By |asHeaders untRows =] Ren 5L, Pivot Column [ convertto List Columr
0. [ | covn: . [asRieadEe
[ Use First Row as Header Any Column
Queri [ Use Headers as First Row b
fr | = Table.TransformColumnTypes (GSTIN_Sheet, {
] GSTIN 1 Account Name GST
= o 2 THE #xxsx+x 10MAACT4262E120Q
3 VIgA**ssx 10MAGFV1540G12ZH
4 SIVA®*#sxass 10MBMFS9662H1ZN
5 VIRGH**skkxss 100VVEK5626F12B
6 VIGN**ss¥xss 10MABFV9177E121
7 SRI ##sxxssss 10MAGFS1915A1ZT
8 RMUT##*ss##x2s 10MEQPM1630J12ZH
Q SRI #¥ssssxssx 10MBDFS9923N1ZN
10 VAHI**ss#% 10MREFV4680K1ZV
11 LAXM 100YPPPE707H

Select PJ Query and select Home Tab->Merge Queries since we want GST numbers
from GSTIN merged with PJ.

| | = | Untitled - Power Query Editor
Ty

Home __Transform  AddColumn  View  Tools  Help

=X D Vi, = [1, [L‘ [ Properties l:l (] - . C= DataType:Date~ B Merge Queries|~| = Text Analytics

= LO 3+ 2 [ advanced Editor X HHE [I] 25 o e st Rowas Heatersgal B2 Waerge cosetes fo
Close& New Recent EntePwgQatasource  Manage  Refresh Choose Remove  Keep Remove Split  Group =
Apply> | Source » Sources = Data ing:  Parameters +  Preview ~ [ Manage Colims = Columng = |- Rows > Rewse Colmn~ By 2 Replace Values T Merge Queridihs New ¢ Machine Leaming
Close New Query Data So®? Parameters Query Manage Columns Reduce Rows  Sort Transform Combine Al Insights

Queries 3] < o Table.TransformColumnTypes(#"Promoted Headers”,{{"Date", type date}, {"Particul ‘type text}, {"GoodsValue”, Currency.Type}, {"Cgst A/C", Currency.Type}, {"Sgst

B3 JsoN
B GSTN
i )

L1 48 particulars ~] $ Goodsvalue ~] $ cestarc <1 $ sesta/c <] $ Total ~] A8 Narration -

12,000.00 0. 00 14,160.00 58

0.00 47,720.00|34

02-07-2023 VR

olw e |win =

03-07-2023 OmM **+

Select the GSTIN query in the bottom and match with Particulars of PJ Query with
Account name of GSTIN query. This is like VLOOKUP function in Excel where we lookup
the field and get the data from another table. Select Left Outer Join ( to keep purchase
data even if there are no GST numbers). Note that the selection matches all 215 rows.



Merge

Select a table and matching columns to create a merged table.

Pl B
Date Particulars  GoodsValue  CgstA/C  SgstA/C  Total  Narmation
02-07-2023 | RAMIK 1200000 108000  1,080.00 14,6000 58
02:07-2023 | VAHI* 4044000 364000 364000 47,72000 34
02:07-2023 VAHI* 4895300 440600 440600 57,765.00 35
02-07-2023 | VAHI® 3282600 295400 295400 3873400 36
02-07-2023 | VAHI® 3025400 272300 272300 3570000 37
GSTIN
JSON I
P (Current)
No preview is a!
Join Kind
Left Outer (all from first, matching from second) -
Use fuzzy matching to perform the merge
b Fuzzy matching options
Cancel

Merge
Select a table and matching columns to create 3 merged table.
] B
Date Particulars joodsValue CgstA/C SgstA/C Total Narration
02-07-2023 RAMK' 1,080.00 1,080.00 14,160.00 58
02-07-2023 | VAHI 364000 3,64000 47,72000 34
02-07-2023 VA 45.95.00NNGd0500 440600 57,765.00 35
02.07-2023 VA 3262600 295400 3873400 36
02.07-2023 VA 3025600 27200 35,70000 37
GSTIN - B
GST
OMAACT4262ETZ0T
10MAGFV1540G1ZH
10MBMFSS662HIZN
100VVPK5626F128
10MABFVI177E121
Join Kind
Left Outer (sl from fist, matching from second) -
Use fuzzy matching to perform the merge
b Fuzzy matching option:
/' The selection mats Jom the first table Cancel

23. Scroll to far right of PJ query to see the merged GSTIN Query and click Expand Button.
Then select only GST Column to get the corresponding GST Numbers of the suppliers.

Data Type: Table
™ Use First Row as Headers

L, , Replace Values

& Merge Queries ~
5 Append Queries v

Combine Files

= Text Analytics
@ vision
A Azure Machine Leaming

Transform Combine Al Insights
", Joinkind.LeftOuter)
§ sestA/C ~| $ Total ~| A% Narration ~

a X

e
gle
ol i [
s 8888

o
2
&

(

©Expand O Aggregate
[® (Select All Columns)

Account Name

« || Query Setings X
4 PROPERTIES
Name
~ PJ
All Properties

4 APPLIED STEPS

B et

Source

Use original column name as prefix

Table
Table
Table
Table
Table
Table
Table
GT/144

159

Table
Table
INVSV23242152 Table
Table

Table

Navigation
Promoted Headers
Changed Type

X Merged Queries

24. Now, the PJ Query will have all the required columns for reconciliation. Both the JSON
and PJ queries are ready for reconciliation. You can see that there are 8 columns in both
the JSON and PJ Queries. This client is not having IGST suppliers. So, there are only 7
common columns having IGST as extra column in JSON query and Particulars as extra

column in PJ Query.

1| & = | Untitied - Power Query Editor
B rove  venstom  Adscowmn  view  Toos  Hep
“x —  Properties
=t L L LT Advance Editor
Close&  Mew Recent Enter  Data source age  Retresn
APpIy™  Source~ Sources~ Data settings  Parameters~  Freview~ [ Manage -

New Query Dsts Sources  Parameters Query

<

= Teble.ExpandTabl

m JsoN

-y o 4
Choose  Remove  Keep Remove
Columns ~ Columns = Rows > Rows ™
Manage Columns

Reduce Rows  Sort

olumn(#"Merged Queries”, "GSTIN", {"GST"}, {*GST

- § Goodsvalue - § Gmac

= Text Analytics

°

Data Type: Date = T Merge Queres -

T Use First Row as Headers = T Append Queres » ion

Spit Group 5
comne 5”43 Reptace Vaues mbine File A £aure Machine Learning
Tanstom Combine Allnsights
~1§ sestaic <] 8 Narration

m GsTIN
Oe

25. Select the PJ Query and Select Home Tab-> Merge Queries-> Merge Queries

as New

since we want to keep PJ and JSON queries in tact after merging.



d | & 5 ' Untitied - Power Query Editor

Tansfom  AddColumn  View  Tools Help
=X ‘ T p— 1y = Properties
-t L L L4 cal © ) avancedtator
Clote&  Mew Recent Enter Ostasource  Mansge  Refresh
Apply~ Source~ Sources~ Data settings  Poameters~  Preew [ Manage -
Close New Query Data Sources  Parameters Query
< /

[ JsoN
0 GSTIN 1

8. Particulars

ExpandTableColumn (s Merged Queries”,

Choose  Remove
Columns * Columns *

Manage Columns

-] § Goodsvalue

Keep Remove
Rows > Rows ™
Reduce Rows

"GSTIN®, {"GST"},

—  DstaType: Date »

‘_

71 Use First Row as Headers »

B Merge Querie: w-
Spit Group
Column= By 3 Reptace Values B Merge Queries as New o
sont Transtorm Combine
{"65T"})
$ cesAlC <1 § setarc $ Towt -] A%, Marration

- % osT -

)]

26

In the Merge window, select JSON in the bottom dropdown. We

can select multiple

common columns to match! It can be done by pressing Ctrl key and Click on the
column headers. Note the the sequence numbers 1, 2, 3... as we select the columns.

Merge

Select tables and matching columns to create a merged table.

p) -
Date Particulars  GoodsValue  CgstA/C  SgstA/C  Total  Namation GsT
02:07-2023 | RAMK*** 1200000 108000  1,080.00 14160.00 58 102UzPR7410/12Y
03-07-2023 | RAMK®** 624000 56200 56200 7,364.00 59 102UZPR7410112Y
03-07-2023 | RAMK=**++"=++ 960000 86400 86400 11,328.00 60 102UZPR7410112Y
04-07-2023 480000 43200 43200 566400 62 102UzPR741012Y
04-07-2023 1500000 135000 135000 17,700.00 63 102UzPR7410/12Y
GSTIN
| JsoN N

2]

No preview is available

Join Kind

Left Outer (all from first, matching from second) -
] Use fuzzy matching to perform the merge
b Fuzzy matching options

OK Cancel

X

X
Merge

Select tables and matching columns to create a merged table.

oodsValue 2

A/C 3 SgstA/C  Total  Namation GsT
12,000.00 1,080.00 14,160.00 58 10ZUZPR7410)12Y
6,240.00 562.00 562.00 7,364.00 59 10ZUZPR7410J12Y
""""" 9,600.00 864.00 864.00 11,328.00 60 10ZUZPR7410J12Y
04-07-20. 4,800.00 432.00 43200 5,664.00 62 10ZUZPR7410J12Y
04-07-2023 5,000.00 ,350.00 1,350.00 17,700.00 63 10ZUZPR7410J12Y

JSON

ctin
10MAGFSI915A1ZT | 17,2400
10MAGFS1915A17T | 17,251

samt | vval  came idt inum
1461900 131571 17-08-2023 SKC/0356

1,315.7) | 14,619.00 1,315.71 24-08-2023 SKC/0379

100YPPPETOTH2ZX | 8,732.00 7,40000 66600 06-08-2023 498/23-24
100YPPPT0TH2ZX | 8732.00 7,400.00 666,00 20-08-2023 549/23-24
100YPPPETOTH2ZX | 8,732.00 7,400.00 666,00 28-08-2023 579/23-24

Join Kind

Left Outer (all from first, matching from st & .
= ‘ Ctrl + Click

Use fuzzy matching to perform the merge

b Fuzzy matching options

I Select the same number of columns from both visible tables to continue.

Cancel

27. Select the relevant 7 common columns from both the queries by matching the selected
column serial numbers 1 to 7 as given below. Note that straight away 105 records are
matching in both the tables. Now Select Inner Join to have only reconciled records.

Click Ok..
Merge

Select tables and matching columns to create a merged table.

04072023

JSON

amt num
10MAGFSIS15A1ZT 1725100 000 131571 1461900 1,31571 17-08-2023 SKC/0356

10MAGFSIO1SAIZT 1725100 000 131571 1461900 131571 24082023 SKC/0379)

100YPPPBI07HZX 873200  0.00 66600 740000 66600 06-08-2023 498/2324
100YPPPSTOTH2IX 873200  0.00 66600 740000 66600 20-08-2023 543/23-24
100YPPPBT07HZZX 873200  0.00 66600 740000 66600 25082023 579/23-24

Join Kind

Left Outer (all from first, matching from second) -

Use fuzzy matching to perform the merge

b Fuzzy matching options

V' The selection mat:hs from the first table.

28. Rename the resultant query to Reconciled1

‘l0zuzPR7A10112Y
102UzPR7410112Y
102UzPR7A1011ZY
102UZPR7A10112Y
102UzPR7410112Y

Merge

Select tables and matching columns to create a merged table.

] - [k
Date 1 Particulars GoodsValue 2 CgstA/C 3 SgstA/C 4 Total 5 Naration & GsT 7
02:07-2023 1200000 108000 108000 1416000 58 102UZPR7410/12Y
03-07-2023 624000 56200 56200 736400 59 102UzPR7410/12Y
03-07-2023 960000 86400 86400 1132800 60 1020zPR7410/12Y
04-07-2023 480000 43200 43200 566400 62 102UZPR7410117Y
04072023 1500000 135000 135000 17,700.00 63 102UzPR7410/12Y
JSON - [

ctin 7 val s csamt  samt 4 boal 2 came 3 it 1 ium s

10MAGFSISISAIZT 1725100 000 131571 1461900 131571 17082023 SKC/036

10MAGFSISISAIZT 1725100 000 131571 1461900 131571 24-08-2023 SKC/0379

100YPPPBT0TH2ZX 873200 000 66600 740000 66600 06-08-2023 498/23-24

100YPPPBT0TH2ZX 873200 000 66600 740000 66600 20-08-2023 549/23-24

100YPPPBTOTH2ZX 673200 000 66600 740000 66600 26-08-2023 579/23-24

Join Kind

Left Outer (all from first, matching from secand) -

Left Outer (all from first, matching from second)

Right Outer (all from second, matching from first)

Full Outer (all rows from both)

Inner (only matching rows) N

Left Anti (rows only in first) Cancel

Right Anti (rows only in second)

Inner (only matching rows)
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Home  Tansform  AddColumn  View Home | Transform  Add Colun
=X =1 \
A GDREBE B B GDE B

Close&  New Recent Enter Datasource  Manage =t

Apply~  Source~ Sources~ Data  settings  Parameter Close&  New  Recent Enter Datasou
Close New Query Data Sources Parametey APV  Source~ Sources~ Data setting
Close New Query Data Sou
Queries [4] < f
= Queries [4] <

B son N oo |
B GSTIN 1 o [ JsoN
8 n z ° @ GSTN 1
& I : =L 2

5 o[D Reconciled! 3

6 2 S 4

7 o 3

8 0 6

9 0 7

10 0 8

29. Right click on the Reconciled1 query and select Duplicate for two times to create two

duplicate queries. This is to make UnreconciledP) and UnreconciledJSON que

d ' & = | Untitied - Power Query Editor

EZW ore eesom  csscoum  vew 1o ] | [H ¥ | Untitled - Power Query Editor 1! E = | Untitled - Power Query Editor

ries.

=x . p— S =
-t L L& EE -8 “ Home Transform Add Colu Home Transform Add Golamn
Close&  New  Recent Enter Datasource  Manage R

Apply*  Source~ Sources~ Data  settings  Parameters~ Pre

¢ e EA ]

LR GLRE &

ng s Close & New Recent  Enter Dataso Close & New Recent  Enter Data source
' Apply~  Source~ Sources~ Data settin  Apply~ Source ¥ Sources~ Data settings
Close New Query DataSo Close New Query Data Sources
B Copy ..
Queries [6] < Queries [6] <
Delete
Rename
ON B 5 SoN
[ ] tnchude in reportrevesh GSTIN 1 E GSTIN
3 Ouplicate
e pJ » B -
MowiTo G ) il 3
Move Up ’ Reconciled 3 & Reconciled! 7
fove e [ UnreconciledP)
—— Reconciled1 2 2 : 5
R = 5 B UnreconciledJSON| h
Reconciled1 (3) 6
L} Advanced Editor 6
& Properties 7
7 7
= 8
2 8 9

30. Select UnreconciledPJ query and right click on Source Step and select Edit
from Applied Steps area.

1| | = | Untitled - Power Query Editor = a

Home Transform Add Column View Tools Help.
=X |—L [\j D [h [\1 2 Properties U AR T Data Type: Date ~ B | = TextAnatics
AN B - B | =
L¢ i 3 e 3. =

LT Advanced Editor i [ Use First Row as Headers ~ @ Vision
Close&  New Recent Enter Datasource  Manage  Refresh Manage Reduce Split  Group Combine
Apply~  Source~ Sources~ Data settings Parameters~  Preview ~ (2] Manage ~ Columns ~ Rows Column~ By ' Replace Values - A Azure Machine Learning
Close New Query DataSources  Parameters Query sort Transform AlInsights
Queries [€] § Jx || = Table.NestedJoin(P1, {"Date”, "GoodsValue", "Cgst A/C", "Sgst A/C", "Total”, | Query Qs
B JSON =. EEE 5 roricers [-] $ Goodsvalue ~11$ cestarc ~| § sesta 4 PROPERTIES
B GsTIN 1 03-07-2023 RRMK*#2*+#%s2 9,600.00 864.00 Name
=] 2 06-08-2023 LAXM»***+¥22 7,400.00 666.00 Q UnreconciledP)
3 Reconciledl 3 04-07-2023 RRMK***=¥¥ssx 4,800.00 432.00 All Properties

- 20-08-2023 LAXM###s#wrss 7,400.00 666.00
[ Unreconciled?) 4 4 APPLIED STEPS
5 04-07-2023 REMR**++¥x¥ss

[ Unreconciled)SON

28-08-2023 LAXM#***¥#%xx -

ﬁd'ﬂsﬂtings

7 05-07-2023 REMK<***#%s%2

8 06-07-2023 RRMKx**x+x%s Bename

9 06-07-2023 REMK=****%s+s 2,430.00 Delete

10 4,500.00 BeidR Rt
1 9,600. 864.00 Insert Step After
12 01-08-2 12,000.00 1,080.00

13 01-08-2023 3 18,000.00 1,620.00 5

14 01-08-2023 REMKA T+ *%%%2 12,000.00 1,020.00

15 04-08-2023 REMK*****¥**% 24,000.00 2,160.00 Extactirevious
16 04-08-2023 REMEw#**#xsxs 6,000.00 540.00 View Native Query
17 10-07-2023 LAXM# #3sxwess 7,400.00 666.00 [ Disgnose

18 04-08-2023 REMK***x*¥*%2 65,000.00 5,850.00 [ Propeties.

19 06-08-2023 REMK<****%+%2 6,000.00 520.00

20 10-07-2023 REMKs**s #5323+ 8,000.00 720.00

Settings

31. Change the Join type from Inner Join to Left Anti (for excluding the common records and

keeping only those records available in PJ only)



X
Merge ! Merge

Select tables and matching columns to create a merged table.

[ Select tables and matching columns to create a merged table. gL
Pl - i) [ - o &
Date 1 Particulars GoodsValue 2 CgstA/C 3 SgstA/C 4 Total s Narration & GST 7 Date 1 Particulars GoodsValue 2 CgstA/C 3 SgstA/C 4 Total 5 Narration & GST 7
02-07-2023 1200000 108000  1080.00 1416000 58 102UZPR7A10112Y 02:07-2023 RAMK=++++==+ 1200000 108000 108000 1416000 5§ 102UzPR7410112Y
05.07-2023 62000 56200 56200 736400 59 TOTUPRIAIONZY 03072023 RAMIK 62000 56200 56200 736400 59 1020zPRTAL0IZY
03072023 el i s s i G 05072023 RAMK 960000 86400 86400 1132800 60 02uzRTALOIZY
04-07-2023 480000 43200 43200 566400 62 102UZPR7410112Y G L GO LD A Fin e iy
04072023 1500000 135000 135000 1770000 63 102UZPR7410112Y CROZAIS] RaMK 00000 325000\ S50 001 14,100.00 65 Ay
= . 150N -
. . . din 7 val s csmt  samt 4 ooal 2ocamt 3 it 1 inum s
o U cont LAl o o 2| uee 2 10MAGFS1915A12T 17,251.00 000 1,31571 1461900 1,31571 17-08-2023 SKC/0356
10MAGFS1915A1ZT  17,251.00 0.00 1,31571 14,619.00 1,31571 17-08-2023 SKC/0356 10MAGFSISISALZT 17,251.00 000 1,315.71 1461900 131571 24-08-2023 SKC/0379
10MAGFS1915A1ZT 17,251.00 000 131571 1461900 1,31571 24-08-2023 SKC/0379 100YPPPET07H2ZX  8,732.00 000 66600 740000 66500 06-08-2023 498/23-24
100YPPPB707H2ZX  8,732.00 000 66600 740000 666.00 06-08-2023 498/23-24 100YPPPS7OTH2ZX  8,732.00 000 66600 740000 66600 20-08-2023 549/23-24
100YPPP8707H2ZX  8,732.00 000 66600 740000 66600 20-08-2023 549/23-24 100YPPPBTOTH2ZX  8,732.00 000 66600 740000 66600 28-08-2023 579/23-24
100YPPPE707H2ZX  8,732.00 000 66600 740000 666.00 28-08-2023 579/23-24
Join Kind
Join Kind (et Anti rows oy in first -]

Inner (only matching rows) Use fuzzy matching to perform the merge
Left Outer (allfrom first, matching from second)
Right Outer (all from second, matching from first) b Fuzzy matching options
Full Outer (all rows from both)
Inner (only matching rows)

R/ The selection excludes 105 of 215 rows from the first table.

Left Anti (rows only in first) N Cancel
Right Anti (rows only in second) = o ToaT e ——
= Left Anti (rows only in first) . o mmmk........, s

32. In the UnreconciledPJ query, we can see that there is a JSON merged query only with

null values. So, right click on the JSON column header and select Remove Column.
[

rose 8 e
Soply~  Source~ Saurces~ Dula

Dota source Marage Reduce
“etings oo~ S

T Usreconcied’SON

T T J e ress mow a3 e -

33. Same way, do it for UnreconciledJSON query with Right Anti Join.

e w2 oo o
° Data sottnan - Bow s L, Replace Values. -
- o
T < Merge R
" Sedect tables and matching colums to create 3 merged table, a4 PRC
T e
y MG
Dete  + Particutans GoodsValue  CEMAC 3 SOEA/C 4 Toted 3 Nerration © o1 7 Any
oo, s 100 116000 %
“an

6000 S0 SR 736400 %
260000 B0 86400 1137800 60
w000 mm  mm sE0 @
1500000 135000 135000 1770000 &

a7 vl s cwm s s Deel tam s k1 um e
IOWAGFIOISAIIT 1725100 000 131571 141900 131571 17082003 SKC/03SE
100 131571 1461900 131571 24082033 SIS

a0 740000 66500 05052023 438/

s75200 74000 65500 20082023 543232
amwm 740000 68600 25082023 ST

34. Now, in the merged query we can see that all the PJ Query columns are having one row
of null values and a JSON column with a table. Right click JSON Column and Remove

other Columns since they are related to PJ. Expand the JSON Column to get
UnreconciledJSON data back.



11 = | Untited -Power Query Edtor o

New  Recent trter Manoge Reduce Gon
Roply=  Soutes Sources~ Dota Columni Roms + 5

Remmere

Remore Ot Coumns
1

e

Select Source queries JSON, GSTIN and PJ, right click and Move them to a group called
Source. This is to organize the queries.

1 | & = | Untitled - Power Query Editor

Home  Transform  Add Column  View  Tools  Help %
X GhhE B B @ g NewGroup

LT Advanced Editor

Close&  New Recent Enter Datasource  Manage  Refresh che
Apply~  Source~ Sources~ Data settings  Parameters~ Preview~ (2] Manage ~ Colu
Close New Query Data Sources  Parameters Query Mz MName
< fr | = Teble.ExpandTableColumn(#"Merged ’ Sou rce|
B Date 28 Particulars
(1 JsoN 8 Parti .
= GSTIN By Copy 02-07-2023 REMK****%#%%+ Description
= P it Paste 03-07-2023 RAMK****%%*+
[ Reconciled1 R — Bt Raie
) PR AT PPy
2] UnreconciledP) MoveTo Group  » New Group... .
U led)SON =
i beconde 6 05-07-2023 RAMK****+#%2
7 05-07-2023 RAMK*****%*x
8 06-07-2023 REMK**=*+#%%2
9 06-07-2023 RAMK****##%%+ c |
10 02-07-2023 VAHI****%% anee
1 02-07-2023 VAEI**=*+

12 02-07-2023 VAHI***+%*

Now let us move to reconcile for next stage. We can see that many records are not
reconciled because of Rounding Off of GST amounts. Hence, this time we can try with
only 5 columns excluding CGST and SGST. Click on UnreconciledPJ and select again
Merge Queries as New. Now we can see another 60 records are matching. Rename the
query as Reconciled2. Like this we can go for further stages to reconcile.

1! & = | Untitled - Power Query Editor
Home Transform Add Column View Tools Help

=X E‘ ”L‘ D ”u [H gy Properties Lt -y, x4 Y i Data Type: Date ~ 3 Merge Queries|*| = Text Analytics
o) o B BHH | : ,
-t L -3 €} avanced Editor x b |z T 7 Use First Row as Headers = | [, Merge Queries n
Close&  New Recent Enter Data source h Choose  Remove Keep Remove split  Group e
Apply~  Source~ Sources~ Data settings  Parameters~ Preview~ ] Manage v Columns ~ Columns~  Rows > Rows ™ Column~ By 2 Replace Values % \Merge Queries asNew & Machine Learning
Close New Query Data Sources  Parameters Query Manage Columns  ReduceRows  Sort Transform e Allnsights
Queries [6] < fc | = Table.RemoveColumns (Source, {"SON"})

41 Source BT Date B, Particulars - 0odsValue -~ gst A -] § sestA - otal
Source [3] B, Dz B Parti G CestA/C /C T

3 JSON

1 02-07-2023 RAMK****w¥sss 12,000.00 1,080.00 080.00
B esTN 2 03-07-2023 RAMK === wxxes 6,240.00 562.00 562.00
= e 3 05-07-2023 RAMKH*»s ¥ %3+

02-07-2023 VAEI*#*##¥*
41 Other Queries (3] 4

5 02-07-2023 VAEI**##¥%
B Reconciled! =

6 02-07-2023 VAHI***# %

[ UnreconciledP)
[ Unreconciled)SON

02-07-2023 VAET***+#%

05-07-2023 AMUT***

10 03-07-2023 GANE#*+swsxss .00
n 09-07-2023 ANNE*#*2+* 2.00 2
12 05-07-2023 RMMB**+*¥#xs s+ .00 703.00

1 09-07-2023 VIJa****+
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Merge
Home Transform Add Column Vi
Select tables and matching columns to create a merged table, =X <
it L [ !

UnreconciledP) - =
Close & New  Recent Enter Datasource N
1 Particulars  GoodsValue 2 CgstA/C  SgstA/C s Apply~  Source~ Sources~ Data settings Par:
020 RAMKessseeess 1200050  1,080.00 410112Y
“ Close New Query Data Sources  Par
03-07-2023 R 6,240.00 562.00 0ZUZPR7410J1ZY
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37. Save the file as a Power Bl file. Select Apply Later.
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38. From the next month onwards or for another client we can change the data source by
selecting the Home Tab -> Data Source Settings.
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39. Click Change Source to change the source folder whenever needed.



Data source settings
Manage settings for data sources that you have connected to using Power Bi Desktop.
@ Data sources in current file Global permissions

Search data source settings

d:\powerbi_projects\icai\gstreconciliation
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Change Sour(e...#% Export PBIDS Edit Permissions... | | Clear Permissions | ~

40. These queries can be executed in Excel Power Query also. In Excel Power Query, we
need to select File->Close & Load or Close & Load to for loading the queries as Excel
Tables for further analysis. Select File->Close & Load to for loading only the selected

queries and not every query.
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From the above case study we can learn how Power Query can be used for reconciling
GST records. From the next month, it is enough if we put the json files in the folder and update the
PJ Excel file, automating the GST Reconciliation.



